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U.S. GOVERNMENT RESTRICTED RIGHTS
This software and documentation are provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government 
is subject to restrictions as set forth in subdivision (b)(3)(ii) of The Rights in Technical Data and Computer Software clause at 
252.227-7013. Contractor/manufacturer is CyberMetrics Corporation.

TRADEMARK ACKNOWLEDGMENTS
All CyberMetrics Corporation products are trademarks or registered trademarks of CyberMetrics Corporation. All other brand 
and product names are trademarks or registered trademarks of their respective holders.

CONTACT INFORMATION
CyberMetrics Corporation 
1523 West Whispering Wind Drive 
Suite 100 
Phoenix, Arizona  85085  USA

Toll-free: 1-800-777-7020 (USA)           
Direct: (480) 922-7300           
Fax: (480) 922-7400  
www.cybermetrics.com 

Technical support is available during normal business hours, Mountain Standard Time:  
1-800-777-7020 ext. 363 
support@cybermetrics.com 
www.cybermetrics.com

Note: technical support cannot be provided unless the user has a current maintenance agreement.

SINGLE USER SOFTWARE LICENSE AGREEMENT
This is a legal agreement between you, the end user and CyberMetrics Corporation (“CyberMetrics”). BY USING THIS 
SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO THE 
TERMS OF THE AGREEMENT, PROMPTLY RETURN THE SOFTWARE AND THE ACCOMPANYING ITEMS (including written 
materials and binders or other containers) TO THE PLACE FROM WHICH YOU OBTAINED THEM FOR A FULL REFUND.

SOFTWARE LICENSE

1. GRANT OF LICENSE. CyberMetrics grants to you the right to use one copy of the enclosed software program (the 
“SOFTWARE”) on a single computer. If you wish to put the SOFTWARE on a network server, you must purchase the same 
number of copies as computers attached to the network that use the SOFTWARE.

2. COPYRIGHT. The SOFTWARE is owned by CyberMetrics or its suppliers and is protected by United States copyright laws 
and international treaty provisions. Therefore, you must treat the SOFTWARE like any other copyrighted material (e.g., a book 
or musical recording) except that you may (a) make copies of the SOFTWARE solely for backup or archival purposes and (b) 
transfer the software to hard disks provided that only one copy of the SOFTWARE is used at any time. You MAY NOT COPY the 
written materials accompanying the SOFTWARE.
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3. OTHER RESTRICTIONS. You may not rent or lease the SOFTWARE, but you may transfer the SOFTWARE and accompanying 
written materials on a permanent basis provided you retain no copies and the recipient agrees to the terms of this Agreement.

LIMITED WARRANTY. CyberMetrics warrants that you may return the SOFTWARE and all accompanying written materials, for any 
reason, for a full refund, for a period of 30 days from the date of receipt. 

CUSTOMER REMEDIES. CyberMetrics’ entire liability and your exclusive remedy shall be, at CyberMetrics’ option, either (a) return 
of the price paid or (b) repair or replacement of the SOFTWARE that does not meet CyberMetrics Limited Warranty and which 
is returned to CyberMetrics with a copy of your invoice or receipt. This Limited Warranty is void if failure of the SOFTWARE has 
resulted from accident, abuse or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original 
warranty period or 30 days, whichever is longer.

NO OTHER WARRANTIES. CyberMetrics DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESSED OR IMPLIED, INCLUDING 
BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH 
RESPECT TO THE SOFTWARE, THE ACCOMPANYING WRITTEN MATERIALS and ANY ACCOMPANYING HARDWARE. THIS 
LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS; YOU MAY HAVE OTHERS WHICH VARY FROM STATE TO STATE.

NO LIABILITY FROM CONSEQUENTIAL DAMAGES. In no event shall CyberMetrics, its distributors, its representatives or its 
suppliers be liable for any damages whatsoever (including, without limitation, damages for the loss of business profits, business 
interruption, loss of business information or other pecuniary loss) arising out of the use or inability to use this CyberMetrics 
product, even if CyberMetrics has been advised of the possibility of such damages. Because some states do not allow the 
exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.
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Welcome
Welcome to GAGEtrak Lite Reports. Reports is an easy-to-use desktop utility that allows you to generate thorough, customized 
reports to analyze and stay ahead of trends, forecast workloads, improve efficiency and minimize costs. Attached to your 
GAGEtrak Lite database, Reports gives you access to all GAGEtrak Lite reports and labels.

As you read through this guide, keep in mind that the screenshots shown may differ slightly from your software, depending on 
your operating system and settings.

Let’s get started!
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Chapter One: Installation
Before installation, it is recommended to close all other programs.

System Requirements
Recommended Hardware and OS Requirements 

• Windows 7, 8 or 10 (64 Bit recommended) 
• Microsoft 4.7 .NET (provided if not installed)
• Hard disk with 350 MB of free space 
• 4 GB RAM required; 8 GB recommended 
• Pentium 2.0 GHz CPU required; 3.00 GHz or higher recommended 
• Display: 1920 x 1080 (16:9 widescreen) for optimal presentation or in 4:3 aspect ratio, 1280 x 1024 minimum 
• Mouse or compatible pointing device 
• Ink-jet or laser printer for printing reports (reports can also be emailed as PDF files) 

 
Network Requirements (Optional - only for multi-user networking)

• Local Area Network 
• Wide Area Network (10 Mbps or better recommended) 

 
SQL Server Database Requirements (Optional)

• Microsoft SQL Server 2016 (32 Bit or 64 Bit)
• Microsoft SQL Server 2014 (32 Bit or 64 Bit)
• Microsoft SQL Server 2012 (32 Bit or 64 Bit)

How to Install
1. Whether you have downloaded your software or requested it on physical media, launch the GAGEtrak Lite Reports 

executable (.exe) file; the Setup screen will open; simply click Install to begin.

2. Follow the on-screen instructions to complete the installation.

3. During installation, you will be prompted to connect to an existing database or skip that step and connect later. Make 
your selection and click Next. If you choose to connect now, the GAGEtrak Connect screen will open to allow that. See 
the Connection Manager section for instructions.

4. When this process is complete, click Finish to close the Data Utility window.

5. Launch Reports by locating its program group in the program list in the Windows Start menu. 
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If Installation Fails
If, for any reason, you can’t install your software or you receive any error messages during installation, try reinstalling. If installation 
fails again, please write down any error messages and call tech support at 1-800-777-7020 for further instructions. 

License Registration
A trigger code is required to register your software license. After installation, obtain this code using the instructions below. If this 
is not completed within 30 days of installation, the software will inform you that the trial period has expired; obtaining a trigger 
code will remove this expiration. Follow these instructions at each workstation on which Reports is installed. 

1. In GAGEtrak Lite Reports, click the application icon  in the upper left corner and then go to Help -> About. In 
the About window, enter the Serial Number that is located on a sticker within your product packaging and then click 
the Register License button; the Register License window will open.  

2. Click the Get Trigger Code Online button or open a Web browser window and go to:  
https://register.cybermetrics.com/. Enter the required information on the web page and then click OK. On the next 
screen, enter the Code Entry and Computer ID numbers from the Register License window and click Get Code. 

3. Your trigger code will then be displayed; copy it and paste it into the Trigger Code field in the Register License 
window and then click OK.

4. Click OK on the confirmation message and then click OK in the About window.
 
Your license will remain registered for the current Windows account on the workstation even if Reports is reinstalled in the future. If you 
have any difficulty generating a trigger code, please contact tech support at 1-800-777-7020 or support@cybermetrics.com.

How to Uninstall
To uninstall, go to the Windows Control Panel -> Programs and Features -> Uninstall or change a program, select GAGEtrak Lite 
Reports and click Uninstall. Once it has been uninstalled, simply remove the program group from the Start Menu and delete the 
GAGEtrak Lite Reports directories. 

Windows 7, 8 and 10 users: by default, GAGEtrak Lite Reports installs in C:\Program Files (x86)\CyberMetrics... 

The install directory can be modified during installation, so a different destination directory may have been selected.

 

https://register.cybermetrics.com/
mailto:support%40cybermetrics.com?subject=GAGEtrak%20Lite%20Trigger%20Code
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Chapter Two: Connection Manager
GAGEtrak Reports provides a data connection tool that allows you to save and edit several connections (to utilize multiple 
databases), making it simple to connect to another GAGEtrak Lite data source without having to re-enter the connection 
information. In the GAGEtrak Reports menu, select Connection Manager to create and save a new database connection. 

After filling out the necessary information and testing the connection, click Save.
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To switch to a different database, open GAGEtrak Reports – Connection Manager and in the form below, click on the 
Connection Name drop-down, select the database to which you would like to connect, and then click Connect:
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Chapter Three: Report Editor Basics
Changing a Field Label
From the GAGEtrak Reports menu, select Report Manager:

Under Report Manager, select Customize Report and click Next:
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Select the report you would like to customize and click Next:

Once you select the report, you will need to change its name:
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Enter the name you would like for your report under Report Name and click Next:

The Report Editor will open. Click on the label you would like to modify and type the new name. Or on the right-hand side of the 
window, under Properties, look for Value and enter the new name you would like for your field title:
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Here’s an example in which Gage ID has been changed to Asset ID:

 

Changing Font Formatting
To change the font type, size, make it bold, italic, underlined or strikethrough, you can find those options on the Format toolbar:
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Changing Text Alignment
Change the text alignment from within the Format menu:

Adding Borders
To add borders to the selected fields, find the Border section of the toolbar where you can choose the desired design:
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Saving Modifications
When you’re finished with your modifications, click the Save icon at the upper left corner of the Report Editor toolbar:

Close the Report Editor by clicking the X at the upper right corner or go to File -> Exit. You may get the following message; click No:

On the following window confirming that your changes have been saved, click Finish:
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Removing a Field (Using a Panel to Preserve Alignment)
If you would like to remove a field from a report, please follow the next steps. We will be using a panel to preserve the alignment 
of the fields and data in the report.

In this example, we will be hiding the Gage S/N label on Gage Listing by Gage ID report. First, move the control to be hidden 
and any control that is to the left and in the same row to a temporary location elsewhere in the report.

Make sure the control’s section is selected - in the menu, select Insert, and insert a Panel.
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Move the panel to the previous location of the controls that were moved in the first step. The exact size of the panel is not 
critical, just be sure it does not overlap any other control.

Move the controls into the panel. Use the red alignment lines to be sure they line up with the other controls.

Set the control’s Visible property to False.

Save the report.

Important Note: Do not put any controls in the panel to the right of the invisible one. These controls will be moved to the left 
because of the invisible control.
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Adding a Field
If you need to add a field to a report, you will first need to realign the existing fields of the report to make space for your new 
field by selecting each field and moving it either right or left. You can also resize the existing fields to make room or you can 
make an existing field invisible and use that space for your new field.

If the field you need is available in the Data Explorer, just select it and drag and drop it to the location of the report where you 
want it to display (look in the following steps for instructions).

If the field is not available in the list, you can add it. In this example, we will cover how to add the Manufacturer field to the 
report.

Once you have an area available for your new field, click on sqlDataSource1, and on the right side under Properties, look for 
Select Command and click the grey [...] box:
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The Configure SQL Data Source form will open; the code in the query will look like the image below, look for the FROM statement:

Right before the From statement, you will find the last field called by the query; add a colon and then type the name of the table 
and field(s) you would like to add to your report, in this example we’re adding Gages.Manufacturer.

Note: If you’re linked to a SQL Server database, the query will look slightly different and when adding a new field, you 
will need to include the schema of the database (GAGETRAK) before the table and field name like: GAGETRAK.Gages.
Manufacturer.

When finished, click the Finish button.
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The Manufacturer field will now display under the Data Explorer section of the Editor:

The next step is to select the Manufacturer field in the Data Explorer, and drag and drop it in the location of the report where you 
want it to display:

The font size and type can be adjusted from the Text Box Tools toolbar.

Next you will need to add a text box for the title of the field. In the Text Box Tools toolbar, find the Text Box option; once you 
select it, move the text box to the location of the report where you need it.
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While the text box is selected, in the Properties pane, look for Value and type the title that you want for your field; in this case it 
will be Manufacturer:

When you’re finished with your modifications, click the Save icon at the upper left corner of the Report Editor toolbar:

Close the Report Editor by clicking the X at the upper right corner or go to File -> Exit. You may get the following message; click No:

On the window confirming that your changes have been saved, click Finish.
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Modifying a Label
To modify a label, from the GAGEtrak Reports menu select Report Manager:

In the Report Manager window, select Customize Report and click Next:
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On the Label Browser tab, select the label you would like to customize and click Next:

Enter the name you would like for your label under Report Name and click Next: 
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In this example, we will make the Company Name that displays at the top of the label invisible. Click on the Company Name field 
to select it, and on the right hand side, under Properties, look for Visible and change it to False.

Note: Not all report properties that are available in this editor are supported by label printers.

Sometimes you need to make changes to the font. In this example, we will change the Date fields to Bold. Click on the fields in 
which you would like to make the font bold (if there are multiple fields just select the first field, and then hold the shift key down 
while selecting the rest of the fields):
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On the toolbar, click the Bold button (or other font options like Italic, Underline or Strikethrough):

From the toolbar, you can also change the font type and/or size of the selected fields:

Note: The same editing options covered in the Report Editing section of this guide apply for labels.

Be sure to save your modifications.
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Chapter Four: Export Reports
If you have modified a report and would like to have it available on another GAGEtrak Lite database, you can export a copy of 
your report and import it into another database.

First, you will need to make sure you’re connected to the database where the modified report is (please refer to the Connection 
Manager section for instructions).

From the GAGEtrak Reports menu, select Report Manager:

In the Report Manager window, select Export Reports and click Next:
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Click the Select button. In the ensuing Select Report window, select the report you would like to export and click OK.

Your selected report appears in the list; click Next:
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The Browse to Folder window will display; browse to the location where you would like to save a copy of the selected report and 
click OK:

You will see the progress of the report being exported; once it is complete, click Finish:
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Chapter Five: Import Reports
To import a report, make sure you’re linked to the database to which you would like to import the report (please refer to the 
Connection Manager section for instructions).

From the GAGEtrak Reports menu, open Report Manager:

In the Report Manager window, select Import Reports and click Next.

Click the Select button and browse to the location where the report you need to import is located:
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The Report Name has to be unique. A suffix of “New 1” will be added to the name of your report, if you already have a report 
with the same name in your database. You will need to rename it on the form below in the Report Name field and then click OK.

Click Next:

You will see the progress of the report being imported; click Finish when it’s complete.
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Chapter Six: Document Control Text
To add or edit text at the footer of a report, from the GAGEtrak Reports menu, select Report Manager:

In the Report Manager window, select Set Document Control Text and click Next.

When you only need to edit one report, under Report Browser, select the Report Group and on the right-hand side, select the 
report. Click Next: 
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To edit multiple reports at once, under All Reports, select all of the reports you need to edit and click Next:

Under Document Control Text, type the text you would like to display at the footer of the report and then click Finish:
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The report will display the text at the footer of the page:

If you are editing multiple reports at once, under Document Control Text, type the text you would like to display at the footer of 
the selected reports and click Finish:



 Conclusion          34GAGEtrak Lite Reports Getting Started Guide

Conclusion
We know you will enjoy using your new GAGEtrak Lite Reports software and we are confident that you will experience increased 
productivity with this easy-to-use product. In addition to this guide, we have included a comprehensive Help System and we 
have a team of experienced support representatives on hand to assist you in your implementation of this product. If, however, 
you would prefer a more comprehensive introduction, please contact us regarding our various training solutions.
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